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Introdução 
R E S U M O  

Esta lição pretende introduzir os alunos ao ambiente da aplicação Flash e à criação e 
publicação de um documento simples. 

Tempo necessário: 1 hora 

Introdução ao Flash 

Visão geral do Flash e das suas principais componentes. 

Criação de um documento Flash 

Comece a utilizar o Flash na criação de um simples documento. Conheça as principais áreas 
da interface do Flash, mude as propriedades do documento, desenhe um elemento, crie um 
símbolo e crie uma simples animação.  

Publicação de um documento Flash 

Compreenda a utilidade da funcionalidade de publicação existente no Flash e, passo a passo, 
publique o documento criado anteriormente.  

Colocação dos ficheiros HTML e SWF na Web 

Para que o seu trabalho possa ficar disponível na Web, é ainda necessário colocar os ficheiros 
resultantes da publicação num servidor Web. Aprenda como o fazer utilizando o servidor 
Web da ESTSP.  

A N T E S  D E  C O M E Ç A R  

Instalar o Flash 8 Professional no computador. Se não tiver acesso ao programa, pode 
descarregar uma versão de teste em http://store1.adobe.com/go/tryflash. 

O  Q U E  É  N E C E S S Á R I O  

Nome de utilizador e palavra passe de acesso à conta no servidor Web da ESTSP. 

Possuir um navegador com Flash Player instalado no seu computador para poder visualizar o 
seu trabalho. 

O B J E C T I V O S  

 Conhecer a interface do Flash 

Lição  1 



Carla Teixeira Lopes  5 

 Criar um documento em Flash 

 Criar um círculo 

 Criar e entender o conceito de símbolo 

 Criar uma pequena animação 

 Publicar um documento em Flash 

 Colocar um documento Flash disponível na Web 
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Introdução ao Flash 
O Flash é uma ferramenta utilizada para criar apresentações, animações, jogos, interfaces, 
aplicações e outros conteúdos que permitam interacção com o utilizador. As aplicações 
desenvolvidas em Flash podem incluir imagens, som, vídeo e efeitos especiais.  

Graças à utilização de imagens vectoriais, os ficheiros Flash ficam com um tamanho reduzido, 
pelo que os conteúdos gerados com esta ferramenta se integram bem num meio como a Web. 
As imagens vectoriais necessitam de menos memória e capacidade de armazenamento porque 
são representados através de fórmulas matemáticas. 

Para criar uma aplicação em Flash trabalha-se num documento Flash que é um ficheiro com a 
extensão .fla (FLA). Neste documento podem ser criados gráficos utilizando as ferramentas 
de desenho disponíveis e podem ser importados elementos externos. Depois define-se como 
e quando é necessário utilizar cada um dos elementos para desenvolver a aplicação desejada. 
Um documento Flash tem 4 componentes principais: 

• Stage – onde as imagens, vídeos, botões e outros elementos aparecem na reprodução da 
aplicação. 

• Timeline – onde se indica quando é que elementos do projecto devem aparecer. Também 
é utilizado para a ordem de sobreposição dos elementos no palco. Os elementos em 
níveis mais altos aparecem à frente de elementos em níveis mais baixos. 

• Library – onde são listados todos os elementos do documento Flash. 

• ActionScript – código que permite adicionar interactividade aos elementos do 
documento. Por exemplo, pode-se adicionar código que faça com que um clique num 
botão faça aparecer uma imagem diferente. O Flash possui componentes de ActionScript 
já implementados, fáceis de incluir no documento Flash.  

Depois de concluído o desenvolvimento da aplicação, deve-se proceder à sua publicação, que 
cria uma versão comprimida do ficheiro com a extensão .swf (SWF). Este ficheiro pode 
depois ser executado como uma aplicação isolada ou num navegador com o Flash Player  (de 
descarregamento gratuito). 

Criação de um documento Flash 
Através dos passos indicados nesta secção irá criar um simples documento Flash.  

1. Abra o Adobe Macromedia Flash 8. 

2. O primeiro ecrã que surge é uma página comum a muitas aplicações Macromedia 
e, se quiser desactivá-la, basta clicar na caixa de selecção “Don’t show again” no 
canto inferior esquerdo. Se quiser voltar a reactivá-la, seleccione 
Edit>Preferences e clique no tabulador General. Seleccione “Show Start 
Page”  e a página abaixo irá aparecer cada vez que o Flash arranca. 
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3. Seleccione Create New>Flash Document na página inicial para abrir a 
interface Flash. Se o Flash não apresentar a página inicial, seleccionar File > New 
do menu para criar um novo documento. Surgirá um ecrã semelhante a: 

 

Como pode verificar a interface é dividida em diversas áreas: 

Menus 

Timeline 

Stage 

Tools 

Painéis 

Property inspector 
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Main Menu 

A barra de menu é o centro de controle da interface Flash. Aqui pode manipular 
os ficheiros Flash e configurar o ambiente de trabalho. 

Stage 

Esta é a área em que o utilizador vê o filme Flash em acção. Contém todos os 
elementos visíveis e, por vezes, elementos invisíveis. 

Timeline 

Contém as frames que integram um filme Flash.  

Painéis 

Dão acesso a uma vasta gama de ferramentas. Podem ser abertos, fechados, 
reorganizados e agrupados. 

Tools 

Ferramentas de desenho e texto. Quando uma ferramenta é seleccionada, o 
Property Inspector apresentará as propriedades associadas à ferramenta. 

Property inspector 

Painel que possibilita a modificação de documentos e objectos. É sensível ao 
contexto, ou seja, o seu conteúdo reflecte o elemento seleccionado no momento. 

4. Seleccionar File>Save do menu principal para gravar o documento. Nomeie o 
ficheiro de primeiro.fla e grave-o num directório específico para este projecto.  

Mudar as propriedades do documento 

5. No Property Inspector, o botão Size apresenta o tamanho actual do Stage (550 x 
400 pixéis). A cor de fundo (background) está definida como branco. Mude a cor 
de fundo para #FF00FF. 

 

Desenhar um círculo 

6. Para desenhar um círculo no ecrã, comece por seleccionar a ferramenta Oval no 
painel Tools. 
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7. No Property Inspector, seleccione a opção No Color no seleccionador da cor do 
limite (Stroke Color). 

 

8. Seleccione a cor #0000FF no seleccionador da cor de preenchimento (Fill 
Color). Desenhe um círculo no Stage seleccionando a Oval Tool e a tecla Shift e 
arrastando o rato no Stage. A utilização da tecla Shift restringe o desenho a um 
círculo. 
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Criar um símbolo 

Pode converter o objecto que acabou de criar num elemento reutilizável, convertendo-o num 
símbolo Flash. Sempre que planear reutilizar um elemento na sua aplicação deve torná-la um 
símbolo e inserir instâncias deste símbolo sempre que necessário. Para criar um símbolo: 

9. Seleccione a ferramenta de Selecção no painel Tools. 

10. Clique no círculo que está no Stage para o seleccionar. 

 

11. Com o círculo seleccionado, seleccione Modify >Convert to Symbol. 

12. Na janela que surge, escreva meu_circulo na caixa de texto do Name.  

 

13. Clique OK. O círculo passa a estar rodeado por um quadrado. 

 

14. O novo símbolo passa a aparecer no painel Library. Se este painel não estiver 
aberto, seleccione Window>Library. 
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Animar o círculo 

15. Arraste o círculo para o lado esquerdo da área do Stage. 

 

16. Clique na Frame 20 do Layer 1 do Timeline. 

 

17. Seleccione Insert>Timeline>Frame. O Flash adiciona frames até à Frame 20, 
que continua seleccionada. 

 

18. .Com a frame 20 seleccionada, seleccione Insert>Timeline>Keyframe. É 
adicionada uma keyframe à Frame 20. Uma keyframe é uma frame em que alguma 
propriedade de um elemento é modificada. Nesta keyframe, irá alterar a posição do 
círculo. 
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19. .Com a frame 20 ainda seleccionada no Timeline, arraste o círculo para o lado 
direito da área do Stage. 

20.  Seleccione a frame 1 do Layer 1 no Timeline. 

21. No Property Inspector, seleccione Motion na caixa de selecção Tween. 

 

Aparecerá uma seta no Layer 1 do Timeline entre as Frames 1 e 20. 

 

Este passo cria uma animação de transição do círculo da posição da frame 1 para 
a posição da frame 20. 

22. No Timeline, arraste a cabeça de leitura vermelha para trás e para a frente entre a 
Frame 1 e a Frame 20 para visualizar a animação. 

23. Seleccione Control>Test Movie para testar o documento FLA. 

24. Feche a janela Test Movie. 

25. Seleccionar File>Save  do menu principal para gravar o documento. 

Publicação de um documento Flash 
Para os utilizadores poderem interagir com a aplicação que acabou de desenvolver, os 
ficheiros com extensão FLA precisam de ser transformados em ficheiros SWF (de 
Small Web Format). A estes ficheiros é comum chamar-se aplicações Flash ou filmes 
porque originalmente o Flash era para criar animações web designadas de filmes. 

É possível executar um filme em Flash de várias formas: 
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• Num navegador que possua o Flash player, introduzindo o endereço da 
página HTML que contem embebido o ficheiro SWF. 

• Pressionando as teclas Control e Enter ou através do menu Control > Test 
Movie directamente a partir do Flash.  

• Abrir o ficheiro SWF directamente, num computador que possua o Flash 
Player. A última versão do Flash Player poderá ser descarregada de 
http://www.macromedia.com/downloads/. 

• Publicar o ficheiro FLA como Windows Projector, o que resultará num 
ficheiro com a extensão exe que poderá ser executado independentemente do 
computador ter ou não o Flash Player.  

Para ser possível visualizar o ficheiro SWF através do navegador é necessário inseri-lo 
numa página web. A funcionalidade Publish do Flash gera automaticamente o 
ficheiro HTML com as marcas necessárias para a inclusão do ficheiro SWF. 

Para publicar o ficheiro FLA criado anteriormente, siga os seguintes passos: 

1. Seleccione File > Publish Settings. 

2. Na janela que surge, seleccione o tabulador Formats e verifique que apenas as 
opções Flash e HTML estão seleccionadas. Desta forma, o Flash gerará dois 
ficheiros, um com extensão HTML e outro com extensão SWF. O ficheiro 
HTML é utilizado para apresentar o ficheiro SWF num navegador. 
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3. Ainda na janela Publish Settings, seleccione o tabulador HTML e verifique 
que no campo Template está seleccionada a opção Flash Only. 

 

4. Clique OK.. 

5. Seleccione File > Publish. Os ficheiros gerados serão gravados na pasta 
onde estava guardado o ficheiro FLA com o mesmo nome que o ficheiro 
FLA. Neste caso chamar-se-ão primeiro.swf e primeiro.html.  

6. Faça um duplo-clique no ficheiro HTML gerado para o abrir no navegador 
(Firefox ou Internet Explorer). Também poderá abrir previamente o 
navegador e depois fazer File > Open no próprio navegador para abrir o 
ficheiro HTML gerado. 

Colocação dos ficheiros HTML e SWF na Web 
Caso pretenda colocar o seu trabalho disponível na Web, acessível a qualquer pessoa que 
possua uma ligação à Internet, terá ainda de colocar os ficheiros HTML e SWF num servidor 
web. A ESTSP possui um servidor web que os alunos podem utilizar para alojamento de 
páginas web.  

Para tornar o seu primeiro trabalho em Flash na Web siga os seguintes passos: 

1. Abra uma janela do Internet Explorer. 
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2. Na caixa endereço, escreva: ftp://www.estsp.pt. 

 

3. Introduza o nome de utilizador e palavra passe que lhe foram fornecidos para 
o endereço de correio electrónico na janela que lhe será apresentada. 

 

4. Depois da autenticação ser-lhe-á apresentada a sua área pessoal no servidor.  
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5. Deverá copiar ambos os ficheiros (primeiro.html e primeiro.swf) para a 
pasta web. Não apague o ficheiro já existente nesta pasta (index.html). 

 

6. Para visualizar na Web o documento Flash que colocou no servidor web, 
deverá agora aceder ao endereço:  

http://www.estsp.pt/~nome_de_utilizador/nome_ficheiro_html  

em que nome_de_utilizador deve ser substituído pelo seu nome de utilizador e 
nome_ficheiro_html deve ser substituído pelo nome e extensão do ficheiro 
HTML (neste caso primeiro.html). Por exemplo, para o aluno com nome de 
utilizador to10000177, o endereço a aceder é: 

http://www.estsp.pt/~to10000177/primeiro.html 
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7. Poderá agora aceder ao seu trabalho a partir de qualquer computador ligado à 
Internet.  
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Ambiente de trabalho do 
Flash 
R E S U M O  

Esta lição pretende introduzir os alunos ao ambiente de trabalho da aplicação Flash às suas 
principais componentes. Serão aqui descritas as funcionalidades mais relevantes, que serão 
simultaneamente aplicadas no início do desenvolvimento de uma aplicação. 

Tempo necessário: 4 horas 

Utilização do painel de ferramentas (Tools Panel) 

Aqui serão apresentadas as ferramentas existentes no painel de ferramentas.  

Utilização do Timeline 

É introduzido o conceito de Timeline, tal como de layers, frames e keyframes, essenciais no 
desenvolvimento de uma aplicação multimédia. 

Utilização da Biblioteca (Library) 

Aqui é descrita a biblioteca de objectos, o painel da biblioteca que permite fazer a gestão dos 
objectos nela existentes. É introduzido o conceito de símbolo e são descritos os 3 grandes 
tipos de símbolos. É também explicado o processo de importação de objectos. 

Posicionamento e alinhamento dos objectos no Palco 

De grande utilidade no posicionamento e alinhamento dos objectos no palco são as réguas, 
grelha, guias e o painel de alinhamento. Estas 4 funcionalidades do Flash são descritas nesta 
Secção.  

A N T E S  D E  C O M E Ç A R  

Instalar o Flash 8 Professional no computador. Se não tiver acesso ao programa, pode 
descarregar uma versão de teste em http://store1.adobe.com/go/tryflash. 

O  Q U E  É  N E C E S S Á R I O  

Nome de utilizador e palavra passe de acesso à conta no servidor Web da ESTSP. 

Possuir um navegador com Flash Player instalado no seu computador para poder visualizar o 
seu trabalho. 

Lição  2 
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O B J E C T I V O S  

 Conhecer a interface do Flash. 

 Saber utilizar as ferramentas do painel de ferramentas. 

 Saber utilizar o timeline. 

 Compreender os conceitos de frame, keyframe e layer. 

 Compreender a necessidade de símbolos. 

 Criar símbolos. 

 Conhecer os vários tipos de símbolos. 

 Alinhar objectos no palco e entre si. 

 Começar a desenvolver os ecrãs de uma pequena aplicação. 
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Utilização do painel de ferramentas (Tools Panel) 
O painel de ferramentas contem um número de ferramentas utilizadas para criar texto, 
desenhos vectoriais e manipular o conteúdo no palco (stage). Quando é seleccionada uma das 
ferramentas, as propriedades associadas à ferramenta serão apresentadas no Property 
Inspector.  

As ferramentas podem ser seleccionadas com o rato ou utilizando o teclado. Para saber qual a 
tecla associada a cada ferramenta, basta passar o rato por cima da ferramenta e visualizar a 
letra que está entre parênteses. Na figura abaixo podemos verificar que a tecla a utilizar para 
seleccionar a ferramenta Lasso Tool é a tecla da letra L. 

 

As ferramentas podem ser agrupadas em 3 grandes grupos: de selecção, desenho e 
transformação. Algumas das ferramentas que serão mais utilizadas são descritas de seguida. 
Pretende-se que à medida que vai lendo a descrição associada a cada ferramenta, a vá 
experimentando. 

• Selecção 

o Selection Tool 

 

Permite seleccionar objectos inteiros ou grupos de objectos através de um clique no 
objecto ou através do desenho de um rectângulo à volta do(s) objecto(s) que se 
pretende seleccionar. 

o Subselection Tool 

 

Permite seleccionar partes de objectos através de um clique ou através do desenho de 
um rectângulo à volta da selecção pretendida. 

o Lasso Tool 

 

Permite seleccionar partes de objectos através de um clique ou através do desenho de 
uma forma qualquer à volta da selecção pretendida. 

Independentemente da ferramenta de selecção escolhida, quando um objecto está 
seleccionado, aparece um rectângulo à volta do objecto e é possível clicar e arrastá-lo para 
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outra posição no palco, tal como mudar as suas propriedades (p.ex. cor de preenchimento 
(Fill Color) no Property Inspector). 

• Desenho 

o Line Tool 

 

Permite desenhar linhas. Com a ferramenta seleccionada deverá clicar no Stage (ponto 
inicial da linha) e arrastar o rato até ao ponto final da linha. 

o Pen Tool 

 

Permite desenhar caminhos curvos e rectilíneos. Os caminhos são desenhados, 
definindo no palco os pontos de intersecção, que depois são interligados por linhas 
rectas ou curvas. 

Para desenhar caminhos rectilíneos, basta clicar no palco para definir o ponto inicial, 
depois voltar a clicar para definir o próximo ponto. O Flash automaticamente une os 
dois pontos através de uma recta. Se desejar interligar mais segmentos de recta, basta 
voltar a clicar no palco para definir os próximos pontos. Quando já tiver terminado, 
basta fazer um duplo-clique no último ponto. Se o objecto for fechado, o Flash 
preenche o objecto com a cor de preenchimento (Fill Color) definida. 

Desenhar caminhos curvos é um pouco mais complicado. Primeiro é necessário 
posicionar o ponteiro do rato no ponto inicial da curva. Depois é preciso arrastar o rato 
na direcção da curva. Será desenhada uma tangente à curva. Depois, deverá posicionar 
o rato no ponto onde a curva deverá terminar e arrastar o rato para a posição contrária 
(à medida que o vai fazendo o Flash vai desenhando a curva, pelo que poderá verificar 
se a curva está a ficar como se pretende). 

o Oval Tool 

 

Para desenhar círculos e elipses no palco. Para desenhar círculos, clique na tecla Shift ao 
mesmo tempo que desenha o círculo no palco. 

o Text Tool 

 

Permite inserir texto no palco. Quando se clica no palco com esta ferramenta activa, o 
Property Inspector altera-se de forma a permitir definir as propriedades do texto como: 
tipo de letra (Font), tamanho da letra (Font Size), cor (Fill Color), entre outras.  

T
h
e
 

T
he 
i
m
ag



L I C Ã O  2  

Carla Teixeira Lopes  22 

o Rectangle Tool 

 

Para desenhar quadrados e rectângulos no palco. Para desenhar quadrados, clique na 
tecla Shift ao mesmo tempo que desenha o quadrado no palco. Se pretender desenhar 
rectângulos com os vértices arredondados, deverá fazer um duplo-clique na ferramenta 
e definir o arredondamento.  

 

Para aceder a esta janela de configuração poderá utilizar também o modificador 
disponível na zona de opções do painel de ferramentas. 

 

o Pencil Tool 

 

Permite desenhar linhas e polígonos diferentes de círculos e rectângulos. Repare como 
o Flash automaticamente endireita a linha. Este comportamento pode ser controlado 
utilizando as opções apresentadas na zona Options do painel de ferramentas. 

 

Aqui é possível optar por um de três modos de desenho: Straighten (tenta 
automaticamente converter o desenho para uma forma geométrica), Smooth (permite 
suavizar as curvas desenhadas) e Ink (para que não seja aplicada nenhuma modificação 
ao desenho). 

o Brush Tool 

 

Permite desenhar “pinceladas” no palco. Através das opções existentes na zona de 
opções poderá definir o tamanho (Brush Size), forma (Brush Shape) e modo (Brush 
Mode) da pincelada. 

T
h
e
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Entre os diversos modos existem o Paint Normal (pinta sobre tudo o que está no 
palco), Paint Fills (restringe as pinceladas a áreas de preenchimento e áreas vazias 
deixando as linhas inalteradas), Paint Behind (restringe as pinceladas a uma área vazia 
por detrás dos objectos já existentes que ficam inalterados), Paint Selection (restringe 
as pinceladas aos objectos seleccionados no momento) e Paint Inside (restringe à 
parte interior do objecto em que se começar a pincelada). 

• Transformação 

o Free Transform Tool 

 

Permite distorcer ou redimensionar um objecto no palco. Dependendo do objecto que 
está seleccionado, permite rodar, enviesar, escalar ou distorcer através das opções 
existentes no painel de ferramentas. 

o Ink Bottle Tool 

 

Permite definir as características do contorno de um objecto. Através do Property 
Inspector é possível alterar também a cor (Stroke color), altura (Stroke height) e estilo 
(Stroke style). Depois de seleccionadas as características pretendidas, basta clicar no 
objecto onde estas se querem aplicar.  

o Paint Bucket Tool 

 

Permite preencher os objectos seleccionados com a cor de preenchimento. Para tal, é 
necessário começar por seleccionar a ferramenta Paint Bucket Tool, definir a cor de 

preenchimento em  no Property Inspector e depois clicar no objecto que se 
pretende preencher. 

Pode também utilizar os preenchimentos gradientes de cor existentes na janela de 
selecção de cores de preenchimento. Experimente clicar em diferentes zonas do 
objecto para ver como o Flash muda o ângulo do gradiente consoante o local onde se 
clica. 
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o Gradient Transform Tool 

 

Permite modificar os preenchimentos gradientes de cor. Para a experimentar, comece 
por criar um objecto cujo preenchimento seja de cor graduada e só depois clique nesta 
ferramenta para modificar o preenchimento. 

o Eraser Tool 

 

Permite apagar parte ou a totalidade de elementos existentes no palco. Possui muitas 
das opções da Brush Tool – permite apagar tudo (Erase Normal), dentro de 
preenchimentos (Erase Fills) ou linhas (Erase Lines), objectos seleccionados (Erase 
Selected Fills) e dentro dos objectos onde se começa a apagar (Erase Inside), 
deixando os restantes elementos do palco inalterados. Para apagar, basta arrastar o rato 
na zona do palco que se pretende apagar. 

É também possível seleccionar o tamanho da borracha através da opção existente na 
zona Options do painel de ferramentas. E xiste ainda a opção Faucet que permite 
apagar tudo que está numa determinada área com um único clique. 

Não se esqueça também que o Flash possui a funcionalidade de Undo (Edit > Undo), que 
permite desfazer o que se fez previamente e voltar à versão anterior do documento.  

Criação de uma aplicação Flash – parte I 
Para o desenvolvimento das competências práticas no Flash, iremos pouco a pouco 
desenvolver uma pequena aplicação multimédia. O desenvolvimento desta aplicação 
acompanhará os conceitos e funcionalidades descritas ao longo deste tutorial. Não se esqueça 
de ir gravando o seu projecto sempre que possível. 

Iremos começar pela criação de um primeiro ecrã da aplicação. 

26. Abra o Adobe Macromedia Flash 8. 

27. Seleccione Create New>Flash Document na página inicial para abrir a 
interface Flash. Se o Flash não apresentar a página inicial, seleccionar File > New 
do menu para criar um novo documento. 

28. Seleccionar File>Save do menu principal para gravar o documento. Nomeie o 
ficheiro de aplicacao.fla e grave-o num directório específico para este projecto.  

29. No Property Inspector, o botão Size apresenta o tamanho actual do Stage (550 x 
400 pixéis). Se não for apresentado este botão no Property Inspector, seleccione a 

Selection Tool ( ) e clique no palco. O Property Inspector já apresenta as 
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propriedades da aplicação. A cor de fundo (background) está definida como 
branco. Mude a cor de fundo para #666600. 

30. Através da Text Tool ( ), escreva no palco a frase: Jogos de Associação. 
No Property Inspector, altere o tipo de letra (Font) para Trebuchet MS, o 
tamanho da letra (Font Size) para 32, a cor (Text color) para branco e defina o estilo 
de letra como negrito (Bold style). 

 

31. Através da Text Tool ( ), escreva no palco a frase: Se estiver pronto para 
os desafios que se seguem, clique no botão Iniciar. No Property Inspector, 
altere o tipo de letra (Font) para Trebuchet MS, o tamanho da letra (Font Size) para 
15, a cor (Text color) para branco e defina o estilo de letra como negrito (Bold style). 

 

32.  Através da Rectangle Tool ( ), desenhe no palco um rectângulo com os 
vértices arredondados em 5 pontos de raio. No Property Inspector, defina a cor da 
linha como invisível ( ), a cor de fundo como branco, a largura (W de width) 
como 90 px e a altura (H de height) como 30 px. 

 

33. Através da Text Tool ( ), escreva em cima do rectângulo que desenhou no 
passo anterior,  a palavra Iniciar. No Property Inspector, altere o tipo de letra 
(Font) para Trebuchet MS, o tamanho da letra (Font Size) para 17, a cor (Text color) 
para #666600 e defina o estilo de letra como negrito (Bold style). 
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34. Seleccionar File>Save As do menu principal para gravar o documento com o 
nome aplicacao_1.fla. 

Utilização do Timeline 
Uma animação é uma sequência de imagens estáticas apresentadas em rápida sucessão. Uma 
apresentação suficientemente rápida ilude o olho humano e cria a ilusão de movimento. Uma 
animação em Flash funciona aproximadamente da mesma forma e a sua manipulação é feita 
através do Timeline. Este é um dos componentes mais utilizados no ambiente Flash e é o local 
de organização e controlo temporal de todos os elementos integrantes da aplicação a 
desenvolver. 

 

Está localizado acima do palco e contem layers e frames.  

Os layers correspondem às linhas e são camadas que podem conter imagens, texto ou 
animações e que se sobrepõem umas às outras.  

As frames correspondem às colunas e são os elementos que permitem o controlo temporal da 
aplicação. Por omissão, a aplicação é executada com a frequência de 12 frames por segundo. A 
caixa rectangular vermelha é a cabeça de leitura que se pode movimentar para visualizar as 
mudanças no palco.  

Os 2 botões no canto superior direito do timeline permitem editar a cena ou editar um dos 
símbolos existentes na biblioteca. 

Layers 

Os layers são uma forma de organização dos elementos. Cada layer pode ser eliminado e 
manipulado de forma independente dos outros layers. Um ficheiro FLA acabado de criar 
contém um único layer, mas é possível adicionar tantos layers quanto os desejados (através do 

botão  que está por baixo da lista de layers). É também possível: 

• mover os layers de posição - basta arrastar o layer para uma posição superior ou inferior 
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• renomear (duplo clique em cima do nome do layer) 

• apagar (clique no layer e arraste para o caixote do lixo que está por baixo da lista de layers 
ou clique com o botão direito no layer e escolha a opção Delete Layer) 

Para modificar um layer, é necessário activá-lo primeiro, através de um clique. Quando o layer 
estiver activo aparecerá um lápis logo após o nome do layer. Mal um layer esteja activo é 
possível manipular os objectos que nele existam, bem como inserir novos objectos. 

Os layers são transparentes por omissão e é possível utilizar os três botões de controlo em 
cada layer para: 

 

• alterar a visibilidade, 

• prender o layer para prevenir alterações indesejadas 

• apresentar apenas os limites dos objectos do layer (em vez  de os apresentar com o 
preenchimento). 

Os layers superior têm prioridade em termos de visibilidade em relação aos layers inferiores, o 
que significa que se os objectos se sobrepuserem os elementos do layer superior prevalecerão 
em termos de visibilidade. 

É uma boa prática colocar cada objecto numa layer diferente de modo a facilitar a 
manipulação e edição dos objectos existentes em dada frame. 

Frames e Keyframes 

Cada layer é composto de uma ou mais frames. Existem dois tipos de frames, as 
normais e as keyframes. Uma keyframe é uma frame em que ocorre uma mudança na 
animação (p.ex. alteração da posição de um elemento – lembra-se da alteração da 
posição do círculo na lição 1?). Deve-se inserir uma keyframe sempre que se quer 
iniciar ou terminar uma mudança. Deve-se pensar nas frames como os limites das 
mudanças. 

É possível distinguir as frames das keyframes no Timeline através da bola preta que aparece no 
fundo de cada keyfraime. 
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As keyframes são adicionadas através de Insert > Timeline > Keyframe ou clicando com o 
botão direito na frame onde se pretende inserir a keyframe e escolhendo a opção Insert 
Keyframe. As frames que seguem a keyframe serão iguais à keyframe. 

Tal como acontece com os layers, também é possível copiar, mover e apagar frames e keyframes. 
É também possível converter uma keyframe para uma frame normal através da opção Clear 
Keyframe acessível através do botão direito do rato. 

Criação de uma aplicação Flash – parte II 
Nesta secção iremos continuar a desenvolver a aplicação que iniciámos na parte I. Iremos 
agora desenhar o segundo ecrã da aplicação. 

1. Se ainda não tiver o Adobe Macromedia Flash 8 aberto, abra-o. 

2. Abra o documento Flash aplicacao_1.fla criado anteriormente. 

3. Clique com o botão direito em cima da frame 5 e seleccione a opção Insert Blank 
Keyframe. O timeline e o palco ficarão semelhantes a: 

 

4. Através da Text Tool ( ), escreva no palco a frase: Desafio 1. No Property 
Inspector, altere o tipo de letra (Font) para Trebuchet MS, o tamanho da letra 
(Font Size) para 32, a cor (Text color) para branco e defina o estilo de letra como 
negrito (Bold style). 
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5. Através da Text Tool ( ), escreva no palco a frase: Clique no elemento do 
grupo 2 que faz parte do grupo 1. No Property Inspector, altere o tipo de letra 
(Font) para Trebuchet MS, o tamanho da letra (Font Size) para 15, a cor (Text color) 
para branco e defina o estilo de letra como negrito (Bold style). 

 

6. Dê um duplo clique no nome do layer onde está a trabalhar (Layer 1) e mude-lhe 
o nome para Cabecalho.  

 

7. Através do botão Insert Layer ( ), adicione um novo layer. Através de um duplo 
clique, dê-lhe o nome de Conteudo.  

 

8. Clique com o botão direito em cima da frame 5 desta nova layer e seleccione a 
opção Insert Blank Keyframe. 

 

9. Desenhe um rectângulo branco no ecrã com 450 px de largura e 300 px de altura. 
Este rectângulo deve ter o vértice inferior esquerdo alinhado com o vértice 
inferior esquerdo do ecrã. Não deve ter os vértices arredondados.  

 

10. Posicione-se na frame 1 e garanta que está a visualizar um ecrã semelhante ao que 
que desenvolveu na primeira parte deste tutorial. 
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11. Volte a posicionar-se na frame 5.  

12. Através do botão Insert Layer ( ), adicione um novo layer. Através de um duplo 
clique, dê-lhe o nome de Grupo1. Clique com o botão direito em cima da frame 5 
desta nova layer e seleccione a opção Insert Blank Keyframe. 

 

13. .Desenhe um rectângulo no palco com os limites de cor #666600 e o interior sem 
cor. A espessura da linha (Stroke height) deve ser de 3 px. 

 

14. .Através da ferramenta de selecção ( ), seleccione as 4 arestas do rectângulo 
que acabou de desenhar. Depois de seleccionar a primeira, seleccione as restantes 
utilizando a tecla Shift enquanto pressiona nas restantes arestas. Esta tecla 
permite adicionar um objecto à selecção (se não for utilizada a selecção anterior é 
eliminada, dando lugar á nova selecção). No menu principal seleccione a opção 
Modify>Group. Esta operação permitiu agrupar as 4 linhas num único elemento 
para que as operações a efectuar ao rectângulo sejam feitas de forma agregada a 
todas as arestas.  

15. Através da ferramenta de selecção ( ), clique numa aresta do rectângulo para 
seleccionar a totalidade do rectângulo. No Property Inspector, altere as 
dimensões do rectângulo para 350 px de largura e 100 px de altura. 
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16. Desenhe um rectângulo no palco com os limites sem cor e o interior de cor 
#666600 com 70 px de largura e 20 px de altura. 

17. Posicione-o alinhado com o canto superior esquerdo do rectângulo que desenhou 
no passo 13. Verifique a figura abaixo. Se necessitar pode fazer zoom in na zona 
onde é feito o alinhamento. Para tal, seleccione a opção View>Zoom In no 
menu principal. 

  

18. De forma semelhante ao que fez no passo 14, seleccione o rectângulo que 
desenhou no passo 13 e o rectângulo que desenhou no passo 6 e agrupe-os 
(Modify>Group). 

19. Através da Text Tool ( ), escreva por cima do rectângulo que desenhou no 
passo 16 a frase: Grupo 1. No Property Inspector, altere o tipo de letra (Font) 
para Trebuchet MS, o tamanho da letra (Font Size) para 14, a cor (Text color) para 
branco e defina o estilo de letra como negrito (Bold style). 

 

20. Através do botão Insert Layer ( ), adicione um novo layer. Através de um duplo 
clique, dê-lhe o nome de Elemento1. Clique com o botão direito em cima da 
frame 5 desta nova layer e seleccione a opção Insert Blank Keyframe. 

 

21. Desenhe um quadrado no palco com 60 px de largura e 60 px de altura. Utilize a 
tecla Shift enquanto arrasta o rato a desenhar para garantir que o objecto final é 
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um quadrado e não um rectângulo. Os limites não devem ter cor e o interior deve 
ser da cor #D5D7E2. 

 

22. Seleccionar File>Save As do menu principal para gravar o documento com o 
nome aplicacao_2.fla. 

Utilização da biblioteca 
A biblioteca (Library panel) é o local onde são armazenados os símbolos criados no Flash, tal 
como ficheiros importados como imagens, sons e vídeos. Neste painel é possível organizar os 
diversos itens em pastas, ver quantas vezes um objecto é utilizado no documento, organizar 
os elementos de acordo com o seu tipo, ver a data de edição do símbolo, o seu nome e tipo.  

 

As bibliotecas podem ser partilhadas entre diferentes aplicações Flash. No Flash existem 
também algumas bibliotecas pré-construídas que contêm símbolos utilizados frequentemente. 

Símbolos 

Símbolos são os blocos de construção das aplicações Flash. São objectos que podem ser 
reutilizados em vários pontos da aplicação. Sempre que um símbolo está no palco designa-se 
por instância, que não é mais do que uma cópia do objecto original que está armazenado na 
biblioteca. A manipulação de uma instância é independente do objecto original e das outras 
instâncias desse mesmo símbolo. No entanto, as mudanças feitas aos símbolos irão afectar 
todas as instâncias filhas. 
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A grande vantagem da utilização de símbolos está relacionada com o tamanho do ficheiro 
SWF que não cresce por se estarem a usar cópias de um mesmo símbolo. Por este motivo, os 
símbolos devem ser utilizados sempre que um objecto seja utilizado mais do que uma vez 
numa determinada aplicação. 

Existem 3 tipos de símbolos: graphic, button e movie clip. Os símbolos gráficos contêm 
normalmente uma imagem que é possível de desenhar no palco. Os botões são movie clips 
de 4 frames que controlam o aspecto e funcionamento do botão. Os botões permitem a 
criação de interactividade com o utilizador. Um movie clip é o tipo de símbolo mais 
utilizado. É uma miniatura de um documento Flash que pode incluir tudo o que um 
documento Flash pode ter, inclusive outros símbolos. 

Uma forma de verificar se uma imagem é um símbolo é verificar se existe um pequeno círculo 
no meio do objecto quando este está seleccionado. 

 

Importação de objectos 

Ao desenvolver uma aplicação em Flash é frequente a necessidade de importar objectos que 
possam ser utilizados. O Flash possui uma funcionalidade que permite importar vários tipos 
como sons, vídeos e imagens de vários formatos (PNG, JPEG, entre outros). Para importar 
um objecto seleccione File > Import to Library, pesquise o ficheiro que tem o objecto a 
importar e seleccione-o. 

 

É importante que antes de importar uma imagem para o Flash, diminua ao máximo o 
tamanho que os seus ficheiros ocupam. Poderá reduzir o tamanho das suas imagens de duas 
grandes formas:  

• se nem toda a área da imagem é relevante, seleccione apenas a área relevante e guarde essa 
área como uma nova imagem 

• comprima a imagem (por exemplo para os formatos PNG, JPEG ou GIF). Se utilizar o 
Photoshop utilize a funcionalidade Save for Web. Se as imagens forem fotografias deverá 
utilizar o formato JPEG, se forem imagens com poucas cores e poucas formas deverá 
utilizar os formatos PNG ou GIF. 

Ao não reduzir o tamanho da imagem, o tamanho do ficheiro SWF crescerá. 
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Criação de uma aplicação Flash – parte III 
Nesta secção iremos continuar a desenvolver o segundo ecrã da aplicação. 

1. Se ainda não tiver o Adobe Macromedia Flash 8 aberto, abra-o. 

2. Abra o documento Flash aplicacao_2.fla criado anteriormente. 

3. Posicione-se na frame 5 da layer Elemento1. No palco deverá aparecer: 

 

4. Como iremos utilizar várias vezes o quadrado que criámos no passo 21 da parte 
II do tutorial, iremos transformá-lo num símbolo. Clique com o botão direito em 
cima do quadrado e escolha a opção Convert to symbol.  

5. Na janela que surge dê o nome ao símbolo (quadradoazul) e indique o seu tipo 
(Graphic). 

 

Na biblioteca irá aparecer um elemento com o nome que acabámos de dar ao 
símbolo. 
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6. Através da Text Tool ( ), escreva por cima do quadrado qe acabou de 
transformar em símbolo a letra minúscula u. No Property Inspector, altere o tipo 
de letra (Font) para Trebuchet MS, o tamanho da letra (Font Size) para 73, a cor 
(Text color) para #666600 e defina o estilo de letra como negrito (Bold style).  

 

7. Seleccione o quadrado e a letra que escreveu no passo anterior e agrupe-os num 
único elemento (Modify>Group). 

8. Através do botão Insert Layer ( ), adicione um novo layer. Através de um duplo 
clique, dê-lhe o nome de Elemento2. Clique com o botão direito em cima da 
frame 5 deste novo layer e seleccione a opção Insert Blank Keyframe. 

 

9.  Vamos criar um segundo elemento que vai integrar o Grupo 1. Como vamos 
necessitar de um quadrado azul semelhante ao que utilizámos para a criação da 
primeira imagem, vamos inserir uma instância do símbolo que criámos nos 
passos 4 e 5. Arraste o símbolo que está na biblioteca para o palco. É 
automaticamente criada uma instância do símbolo. 

 

10.  Através da Text Tool ( ), escreva por cima do quadrado que acabou de 
transformar em símbolo a letra minúscula e. No Property Inspector, altere o tipo 
de letra (Font) para Trebuchet MS, o tamanho da letra (Font Size) para 73, a cor 
(Text color) para #666600 e defina o estilo de letra como negrito (Bold style).  
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11. Seleccione o quadrado e a letra que escreveu no passo anterior e agrupe-os num 
único elemento (Modify>Group). 

12. Através do botão Insert Layer ( ), adicione um novo layer. Através de um duplo 
clique, dê-lhe o nome de Elemento3. Clique com o botão direito em cima da 
frame 5 deste novo layer e seleccione a opção Insert Blank Keyframe. 

 

13. Para criar o terceiro e último elemento do Grupo 1, irá repetir os passos 9, 10 e 
11 e criar uma imagem com um ?. O tamanho da letra deve ser 65 e não 73 como 
no passo 10. Visualize o resultado final na imagem seguinte. 

 

14. .Através do botão Insert Layer ( ), adicione um novo layer. Através de um 
duplo clique, dê-lhe o nome de Grupo2. Clique com o botão direito em cima da 
frame 5 deste novo layer e seleccione a opção Insert Blank Keyframe. 
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15. No passo 19 da parte II deste tutorial tinha acabado de criar a caixa que envolve 
os elementos do grupo 1. Como vamos necessitar de utilizar essa mesma caixa, 
vamos torná-la num símbolo. Clique com o botão direito em cima da caixa e 
seleccione a opção Convert to Symbol. Este símbolo deve-se chamar 
caixagrupo e ser do tipo Graphic.  

 

Se com a conversão a frase Grupo 1 desaparecer, basta clicar com o botão direito na 
caixa e seleccionar a opção Arrange>Send Backward. 

16. Arraste o símbolo caixagrupo que está na biblioteca para o palco. É 
automaticamente criada uma instância do símbolo. 

 

17. Copie a caixa de texto que tem escrito Grupo 1 e volte a colar. Altere o seu 
conteúdo para Grupo 2 e posicione-a de forma semelhante ao que fez para o 
Grupo 1. 

 

18. De forma semelhante ao que fez para os elementos do Grupo 1 (passos 8, 9, 10 e 
11) irá criar 3 elementos para o Grupo 2 com as letras: c, a e b. Os novos layers 
devem chamar-se Elemento4, Elemento5 e Elemento6. 
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19. Através do botão Insert Layer ( ), adicione um novo layer. Através de um duplo 
clique, dê-lhe o nome de Navegacao. Clique com o botão direito em cima da 
frame 5 deste novo layer e seleccione a opção Insert Blank Keyframe. 

20. Como vamos necessitar de utilizar um botão com uma imagem semelhante ao 
rectângulo Iniciar que desenhamos na primeira frame da aplicação, iremos tornar 
esse rectângulo um símbolo. Posicione-se na frame 1. Clique com o botão direito 
do rato no rectângulo branco e escolha a opção Convert to Symbol. Este 
símbolo será do tipo Graphic e chamar-se-á rectangulobotao. 

 

21.  Volte a posicionar-se na frame 5 do layer Navegacao.  

22. Arraste por duas vezes o símbolo rectangulobotao para o canto inferior direito 
do ecrã.  



L I C Ã O  2  

Carla Teixeira Lopes  39 

 

23. Através da Text Tool ( ), escreva em cima das instâncias do rectângulo 
branco que inseriu no passo anterior, a palavra Início e Fim. No Property 
Inspector, altere o tipo de letra (Font) para Trebuchet MS, o tamanho da letra 
(Font Size) para 17, a cor (Text color) para #666600 e defina o estilo de letra 
como negrito (Bold style). 

 

24. Seleccionar File>Save As do menu principal para gravar o documento com o 
nome aplicacao_3.fla. 

Posicionamento e alinhamento dos objectos no palco 
Posicionamento 

O Flash possui 3 ferramentas que são úteis no posicionamento dos objectos no palco: réguas 
(rulers), grelha (grid) e guias (guides). As guias são muito úteis no posicionamento preciso dos 
objectos. 

Para activar as réguas, deverá seleccionar View > Rulers. 
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O palco passará de: 

 

a: 

 

Para activar a grelha deverá seleccionar View > Grid. 

O palco passará de: 

 

a: 
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As guias são linhas horizontais e verticais úteis no posicionamento e alinhamento dos 
objectos no palco. Para desenhar uma guia horizontal deve clicar na régua horizontal e 
arrastar o rato para baixo. Para desenhar uma guia vertical deve clicar na régua vertical e 
arrastar o rato para a direita. Para o funcionamento das guias é necessário que as réguas 
estejam activas. Na figura seguinte é possível visualizar-se duas guias horizontais e uma guia 
vertical. 

 

Para mudar a cor das guias seleccionar View > Edit Guides e alterar a cor seleccionada. Para 
remover as guias, basta clicar nelas e arrastá-las em direcção às réguas. 

Também úteis no posicionamento são as coordenadas X e Y de cada objecto que são visíveis 
na janela Property Inspector: 

 

Alinhamento 

Para além das ferramentas descritas na secção anterior, existe também um painel de 
alinhamento (Align panel) que permite alinhar objectos entre si ou alinhar objectos com o 
palco. Para abrir este painel deverá seleccionar Window > Align. 
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Este painel permite alinhar objectos seleccionados de acordo com um eixo vertical e 
horizontal. Verticalmente é possível alinhar pela aresta esquerda, centro ou aresta 
direita dos objectos seleccionados. Horizontalmente é possível alinhar pela aresta 
superior, centro ou aresta inferior dos objectos seleccionados. As arestas são 
determinadas pelas caixas que envolvem cada objecto seleccionado. 

Também é possível neste painel, distribuir objectos para que os seus centros ou 
arestas estejam espaçados de igual distância. Existe também uma opção para 
redimensionar todos os objectos seleccionados para que as suas dimensões verticais 
ou horizontais igualem a do maior objecto. É também possível alinhar os objectos 
seleccionados ao palco e aplicar mais do que uma opção de alinhamento aos objectos 
seleccionados. 

Criação de uma aplicação Flash – parte IV 

Nesta parte do tutorial irá verificar e ajustar o alinhamento dado aos objectos já criados para 
os dois primeiros ecrãs da aplicação. 

1. Se ainda não tiver o Adobe Macromedia Flash 8 aberto, abra-o. 

2. Abra o documento Flash aplicacao_3.fla criado anteriormente. 

3. Posicione-se na frame 1 do layer Cabecalho.  

 

4. Agrupe o rectângulo branco e a caixa de texto Iniciar.  

5. Seleccione a caixa de texto Jogos de Associação e no Property Inspector defina a 
coordenada x como 100. 

6. Repita o processo do passo 5 para os outros dois elementos existentes nesta frame 
(a outra caixa de texto e o grupo que se assemelha a um botão) para que fiquem 
todos na coordenada X=100.  

7. Posicione-se na frame 5 de qualquer layer. 
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8. Para alinhar à esquerda as duas caixas de texto existentes no cabeçalho e as caixas 
do Grupo 1 e 2 poderá fazer o mesmo que fez no passo 5 e 6 ou poderá utilizar o 
painel de alinhamento. Para abrir este painel deverá seleccionar Window > 
Align. 

 

9. Seleccione todos os elementos que estão nos layers Cabecalho, Grupo1 e 
Grupo2, ou seja, as duas caixas de texto do cabeçalho, as duas caixas verdes que 
abrangem os elementos dos grupos e as duas caixas de texto que dizem Grupo 1 
e Grupo 2. Poderá fazê-lo facilmente pressionando o rato no nome de um dos 
layers (que automaticamente selecciona todos os objectos nesse layer) e repetindo o 
processo para os outros layers enquanto pressiona a tecla Ctrl. Esta tecla permite 
adicionar à selecção elementos não contíguos (a utilização da tecla tecla Shift 
acrescentaria todos os layers entre o primeiro e o segundo layer seleccionados).  

10. No painel de alinhamento seleccione a opção Align left edge. Esta opção irá 
alinhar todos os elementos pela aresta mais à esquerda. 

11. Agrupe o rectângulo branco e a caixa de texto Início.  

12. Agrupe o rectângulo branco e a caixa de texto Fim.  

13. Seleccione os dois agrupamentos que fez no passo 11 e 12 e, no painel de 
alinhamento, seleccione a opção Align horizontal center. Esta opção irá alinhar 
os dois objectos pela coordenada X média entre a aresta mais à esquerda dos dois 
elementos e a aresta mais à direita dos dois elementos. Garanta que ficam ambos 
os botões dentro da área do palco. 
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14. Seleccione o agrupamento que fez no passo 12 e a caixa verde que abrange os 
elementos do grupo 2. No painel de alinhamento seleccione a opção Align 
bottom edge. Esta opção irá alinhar os dois objectos pela aresta mais inferior 
dos dois elementos. 

15. Seleccione a caixa que contém a letra u e a caixa que contém a letra c e escolha a 
opção Align horizontal center do painel de alinhamento. Repita o processo para 
as letras e e a e para as letras ? e b. 

16. Seleccione o elemento 4, 5 e 6 (caixas com letras c, a e b) e escolha a opção 
Distribute left edge. As opções Distribute só funcionam quando se selecciona 
3 ou mais elementos e esta opção em particular distribui os elementos de forma a 
existir o mesmo espaçamento vertical entre eles (nesta caso calculado a partir da 
aresta da esquerda). 

17. Para fazer a verificação final dos alinhamentos active as réguas (View>Rulers). 
Clicando na régua vertical arraste uma guia para a direita. Verifique se os 
alinhamentos estão bem feitos. 

 

18. Seleccionar File>Save As do menu principal para gravar o documento com o 
nome aplicacao_4.fla 

Criação de uma aplicação Flash – parte V 

Para praticar o que foi apresentado nesta lição, irá elaborar mais 2 ecrãs da aplicação. 

1. Se ainda não tiver o Adobe Macromedia Flash 8 aberto, abra-o. 

2. Abra o documento Flash aplicacao_4.fla criado anteriormente. 

3. Clique com o botão direito na frame 10 do layer Cabecalho e seleccione a opção 
Insert Keyframe. Repare que esta opção é diferente da utilizada anteriormente 
(Insert Blank Keyframe). Com esta opção é inserida uma keyframe, mas o 
conteúdo da última keyframe permanece. Repita este processo para todos os layers. 
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4. Tendo o cuidado de estar posicionado na frame 10, altere o conteúdo de forma a 
obter o ecrã seguinte. Tenha atenção à disposição correcta dos elementos nos 
layers (ver indicações depois da imagem). 

 

O rectângulo com a palavra Próximo deve estar no layer Navegacao e a caixa de texto 
existente no rectângulo Razão deve estar inserida no layer Elemento4. A caixa de texto 
Solução deve estar no layer Grupo1 e a caixa de texto Razão deve estar no layer Grupo2. 
Os layers Elemento5 e Elemento6 ficam vazios. 

5. Clique com o botão direito na frame 100 do layer Cabecalho e seleccione a opção 
Insert Blank Keyframe. Repita este processo para todos os layers. 

6. Posicione-se na frame 1 e seleccione todos os objectos. No menu principal 
seleccione a opção Edit>Copy. 

7. Posicione-se na frame 100 do layer Cabecalho e no menu principal seleccione a 
opção Edit > Paste in Place. Altere a segunda caixa de texto para conter a 
seguinte frase: Obrigado por participar neste desafio. Se desejar voltar a 
começar, clique no botão Iniciar. O ecrã deverá ficar semelhante a: 
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8. No final deve verificar se o conteúdo das frames 1, 5, 10 e 100 são iguais a:  

  

  

 

9. Seleccionar File>Save As do menu principal para gravar o documento com o 
nome aplicacao_5.fla. 
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Criação de 
interactividade 
R E S U M O  

No Flash não se está limitado a executar cada frame de forma sequencial. É possível controlar 
a execução das frames e o comportamento de determinados elementos existentes no palco. 
Esta lição pretende introduzir os alunos algumas formas de criação de interactividade no 
Flash. 

Tempo necessário: 4 horas 

Introdução ao ActionScript 

Nesta secção é feita uma introdução à linguagem de programação existente no Flash e é 
explicada a forma de controlar a execução de frames no timeline. 

Criação de botões 

Nesta secção são apresentados os passos que permitem criar botões ou zonas com as quais os 
utilizadores poderão interagir. É também descrita a utilização dos vários estados associados a 
um botão que, entre outros, permitem criar animações. 

Inserção de áudio no documento Flash 

Aqui são apresentadas formas de inserção de áudio em documentos Flash. É descrita a forma 
de importação de ficheiros deste tipo e a sua associação a eventos e a estados de botões. 

Drag and Drop no Flash 

A última forma de interactividade abordada neste tutorial é a técnica de Drag and Drop. Aqui 
é explicada a sua forma de implementação. 

A N T E S  D E  C O M E Ç A R  

Instalar o Flash 8 Professional no computador. Se não tiver acesso ao programa, pode 
descarregar uma versão de teste em http://store1.adobe.com/go/tryflash. 

Lição  3 



 

Carla Teixeira Lopes  48 

O  Q U E  É  N E C E S S Á R I O  

Nome de utilizador e palavra passe de acesso à conta no servidor Web da ESTSP. 

Descarregar o conjunto de ficheiros (licao3.zip) que contém ficheiros (gromb.mp3, 
sucesso.mp3, a.mp3, comsom.jpg e semsom.jpg) que necessitará de importar para o 
documento Flash. 

O B J E C T I V O S  

 Compreender a utilidade do ActionScript. 

 Escrever simples blocos de instrução em ActionScript. 

 Compreender simples blocos de instrução em ActionScript. 

 Criar botões. 

 Associar acções a botões. 

 Mudar o aspecto de botões consoante o seu estado. 

 Importar ficheiros de áudio para um documento Flash. 

 Importar imagens externas para um documento Flash. 

 Associar áudio a eventos num botão. 

 Associar áudio a estados de um botão. 

 Criar um objecto que possa estar sujeito a Drag and Drop no palco. 

 Detectar se um objecto foi arrastado para cima de um determinado objecto e, em caso 
positivo, actualizar as suas coordenadas. 

 Detectar se todos os objectos foram deslocados para os locais pretendidos e efectuar a 
acção desejada. 
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Introdução ao ActionScript 
ActionScript é uma linguagem de programação utilizada para adicionar interactividade às 
aplicações Flash. No Flash 8 Professional é utilizado o ActionScript 2.0. 

Sendo uma linguagem de programação, muito haveria a dizer sobre o ActionScript. No entanto, 
tendo em conta o contexto em que este tutorial se insere, serão apenas retratadas as funções 
essenciais para a inserção de interactividade numa aplicação para o desempenho perceptivo-
cognitivo. 

O código ActionScript pode ser adicionado às frames no timeline ou a objectos do palco como 
botões e vídeos.  

Movimentação entre frames 

Apesar de as frames no timeline estarem organizadas de forma sequencial, não necessitam de ser 
executadas de forma sequencial.  

Após a conclusão da lição 2 deste tutorial, a sua aplicação possui 4 ecrãs. Nesta lição iremos 
adicionar interactividade à movimentação entre frames. 

10. Se ainda não tiver o Adobe Macromedia Flash 8 aberto, abra-o. 

11. Abra o documento Flash aplicacao_5.fla criado anteriormente. 

12. Seleccione Control > Test Movie para ver a execução sequencial das várias cenas. 

13. Posicione-se na frame 1. 

 

Conforme pode deduzir pelo conteúdo desta frame, apenas se pretende que a aplicação 
passe para a próxima frame (neste caso, a frame 5) quando o utilizador clicar no botão 
Iniciar. Para evitarmos que a execução “salte” para a próxima frame, iremos adicionar 
código actionscript à frame 1 para indicar que a execução deve parar. 

14. Através do botão Insert Layer ( ), adicione um novo layer. Através de um duplo 
clique, dê-lhe o nome de ActionScript. Todo o código ActionScript deverá estar 
neste layer. 
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15. Clique com o botão direito na frame 1 do layer ActionScript e escolha a opção 
Actions. O palco será substituído pela janela de Acções (Actions). 

 

 

Esta janela também pode ser aberta através do comando Window > Actions. Está dividida 
em 4 secções:  

• painel de código – local onde é escrito o código ActionScript. 

• painel de acções – é um “dicionário” de ActionScript. Contém uma série de “livros” que 
podem ser abertos com um clique. Quando um livro está aberto são apresentadas as suas 
funções. Com um duplo clique num deles, este é inserido no painel de código. 

• painel de scripts – permite rapidamente visualizar e modificar os outros pedaços de 
código existentes na aplicação. 

• barra de ferramentas – contém botões que permitem escolher a versão do ActionScript, 
abrir o Assistente de Scripts (Script Assist), etc. 

16.  Com um clique no painel de acções abra o livro Global Functions.  

 

17. Com um clique no painel de acções abra o livro Timeline Control.  

Painel de 
código Painel 

de 
acções 

Painel de 
scripts 

Barra de 
ferramentas 
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18. Com um duplo clique em stop, insira esta função no painel de código. 

 

Esta função fará com que a execução da aplicação pare nesta frame até que outro evento seja 
desencadeado. 

19. .Feche a janela de Acções através de Window>Actions. 

20. Seleccione Control > Test Movie para ver a execução da aplicação. Agora a 
aplicação não passa desta primeira frame. 

21. Seleccionar File>Save As do menu principal para gravar o documento com o nome 
aplicacao_6.fla. 

Criação de botões 
Os botões são simplesmente elementos (movie clips com 4 frames) em que os utilizadores podem 
clicar para determinada acção ser desencadeada. Para tornar um botão interactivo, basta inserir 
uma instância de um símbolo do tipo botão no palco e atribuir acções à instância do botão.   

Na Secção anterior já indicamos que a execução da aplicação deve parar na frame 1 e esperar que 
outro evento seja desencadeado e permita que a execução prossiga. Esse evento será o clicar do 
utilizador no botão Iniciar. Nos próximos passos iremos adicionar interactividade à imagem já 
existente na frame 1. 

1. Se ainda não tiver o Adobe Macromedia Flash 8 aberto, abra-o. 

2. Abra o documento Flash aplicacao_6.fla criado anteriormente. 

3. Posicione-se numa layer qualquer da frame 1. 
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4. Se o rectângulo branco e a palavra Iniciar não forem um grupo, deverá agrupá-los 
(Modify > Group). 

5. Clique com o botão direito no agrupamento (rectângulo branco + Iniciar) e 
seleccione a opção Convert to Symbol. Na janela que surge defina o nome do 
botão (bt_iniciar) e o tipo (Button). Na biblioteca irá surgir o novo símbolo. 

 

 

6. Clique com o botão direito do rato no botão Iniciar e seleccione a opção Actions. O 
palco será substituído pela janela de Acções (Actions). 

7. O código a adicionar permitirá definir o comportamento do botão. Com um clique 
no painel de acções abra o livro Global Functions.  

 

8. Com um clique no painel de acções abra o livro Movie Clip Control.  
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9. Com um duplo clique em on, insira esta função no painel de código. No painel de 
código aparece uma caixa de selecção conforme figura abaixo. 

 

10. Nesta caixa de selecção deve escolher o evento que pretende detectar no botão, ou 
seja, o evento que ao acontecer desencadeará uma acção (p.ex. mudança de frame). 
Seleccione release. Esta escolha significa que a acção será desencadeada quando o 
utilizador está a largar (release) o botão do rato, após ter pressionado o botão. 

 

11. Entre as duas chavetas é necessário indicar a acção a desencadear quando acontece o 
libertar do botão do rato, que neste caso corresponde a ir para a frame 5. Coloque o 
rato após a primeira chaveta e carregue no enter. Clique na segunda linha. 

12. Com um clique no painel de acções abra o livro Timeline Control.  
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13. Com um duplo clique em gotoAndStop, insira esta função no painel de código. 

 

14. Esta é uma função que pode ter um ou dois argumentos. Vamos utilizar apenas um 
argumento que é o número da frame para onde queremos que a aplicação vá. Quando 
o botão é pressionado queremos que a aplicação vá para o primeiro desafio, que está 
na frame 5. Desta forma, iremos escrever o número 5 como argumento da função 
gotoAndStop. 

 

22. .Feche a janela de Acções através de Window>Actions. 

23. Seleccione Control > Test Movie para ver a execução da aplicação. Experimente 
pressionar o botão Iniciar. 

24. Seleccionar File>Save As do menu principal para gravar o documento com o nome 
aplicacao_7.fla. 

25. .Posicione-se na frame 5. 

 

Neste ecrã existem 5 elementos que podem ser pressionados: a letra c, letra a, letra b, o 
rectângulo Início e o rectângulo Fim. 

26. . Se o quadrado azul e a letra a não forem um grupo, deverá agrupá-los (Modify > 
Group). 

27. Clique com o botão direito no agrupamento e seleccione a opção Convert to Symbol. 
Na janela que surge defina o nome do botão (bt_a) e o tipo (Button).  

28. Clique com o botão direito do rato no botão com a letra a e seleccione a opção 
Actions. O palco será substituído pela janela de Acções (Actions). 
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29. O código a adicionar permitirá definir o comportamento do botão. Com um clique 
no painel de acções abra o livro Global Functions e depois o livro Movie Clip 
Control. Com um duplo clique em on, insira esta função no painel de código. Nesta 
caixa de selecção escolha release. Esta escolha significa que a acção será 
desencadeada quando o utilizador está a largar (release) o botão do rato, após ter 
pressionado o botão. 

 

30. Após ter colocado o rato entre na linha intermédia às duas chavetas, abra o livro 
Timeline Control e com um duplo clique em gotoAndStop, insira esta função no 
painel de código. 

 

31. Quando o utilizador pressiona a letra a, consegue completar com sucesso o desafio. 
Desta forma, deverá passar para a frame 10. Tal como fizemos no passo 14 
poderíamos indicar a frame 10 como argumento da função gotoAndStop. No 
entanto, como pretendemos que este código possa ser reutilizado, podemos utilizar 
uma variável que contém o número da frame actual. Essa variável chama-se 
_currentFrame. O argumento da função gotoAndStop deverá ser 
_currentFrame+5. Desta forma, será possível reutilizar este código noutros botões 
cuja acção seja avançar 5 frames (se não utilizássemos uma variável em cada botão 
teríamos de fazer os cálculos manualmente e alterar o código). 

 

32. .Feche a janela de Acções através de Window>Actions. 

33. Seleccione Control > Test Movie para ver a execução da aplicação. Experimente 
pressionar o botão Iniciar. 

34. Seleccionar File>Save As do menu principal para gravar o documento com o nome 
aplicacao_8.fla. 

35. Volte a repetir o processo dos passos 18 a 24 para os outros 4 elementos que 
necessitam de interactividade. Na letra c e b, a função on (release) não tem qualquer 
código dentro das chavetas, já que o utilizador pressiona a opção errada e como tal 
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deve ficar na mesma frame para voltar a tentar. No botão Início, o utilizador deve ser 
direccionado para a frame 1 e no botão Fim deve ser direccionado para a frame 100. 

36. Seleccione Control > Test Movie para ver a execução da aplicação. Experimente 
pressionar o botão Iniciar. 

37. Seleccionar File>Save As do menu principal para gravar o documento com o nome 
aplicacao_9.fla. 

O Flash tem também uma biblioteca de botões que pode utilizar no seu documento Flash. 
Para visualizar esta biblioteca, depois de terminar esta lição, seleccione Window > Common 
Libraries e seleccione a biblioteca dos botões. 

Criação de animação nos botões 

Quando se cria um símbolo do tipo botão, o Flash cria uma timeline para o botão com quatro 
frames. Cada uma tem uma função específica: 

• A primeira frame corresponde ao estado Up, ou seja, é o botão quando o ponteiro do rato não 
está sobre ele. 

• A segunda frame corresponde ao estado Over, ou seja, é o botão quando o ponteiro do rato 
está sobre ele. 

• A terceira frame corresponde ao estado Down, ou seja, é o botão quando está a ser 
pressionado pelo rato. 

• A quarta frame corresponde ao estado Hit, ou seja, define a área activa do botão, à área que 
responde ao pressionar do rato. Esta área é invisível.  

O timeline dos botões não é executado da mesma forma que o timeline da aplicação Flash, 
simplesmente reage ao movimento e acções do ponteiro do rato, saltando para as frames 
apropriadas. 

Nesta secção do tutorial iremos alterar o estado Over dos botões criados anteriormente, para criar 
a sensação de se estar a pressionar um botão. 

1. Se ainda não tiver o Adobe Macromedia Flash 8 aberto, abra-o. 

2. Abra o documento Flash aplicacao_9.fla criado anteriormente. 

3. Posicione-se na frame 5. 
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4. Antes de editar os vários estados dos botões, iremos criar um novo símbolo com base 
no símbolo criado anteriormente chamado quadradoazul. Na biblioteca carregue 
com o botão direito do rato no símbolo quadradoazul (que deve ser do tipo Graphic 
conforme criação no passo 5 da parte III da Lição 2) e seleccione a opção Duplicate. 
Nomeie o novo símbolo de quadradoverde. 

5. Na biblioteca, clique com o botão direito em cima do símbolo quadradoverde e 
seleccione a opção Edit. O palco é substituído pelo espaço de edição deste símbolo. 
Repare durante a edição do símbolo, o timeline apresenta após o Scene 1 o nome do 
símbolo em edição.  

 

6. Altere a cor do quadrado para #666600. 

7. Para terminar a edição do símbolo quadradoverde, clique em Scene 1 existente no 
Timeline. 

8. Dê um duplo clique no botão c. O timeline da aplicação é substituído pelo timeline 
do botão e são apresentados os quatro estados do botão. 

 

9. Clique com o botão direito do rato na frame do estado Over e seleccione a opção 
Insert Keyframe. O conteúdo da frame Up será copiado para a frame Over. 

 

10. .Seleccione o botão e no menu principal escolha a opção Modify > Ungroup. Esta 
operação permitirá desagrupar o texto do quadrado, para os podermos alterar 
separadamente. 
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11. Seleccione a caixa de texto e altere a cor do texto para #D5D7E2. 

12. Clique com o botão direito no quadrado de forma a seleccioná-lo e escolha a opção 
Swap Symbol. Escolha então o símbolo quadradoverde.  

13. Para terminar a edição do botão, clique em Scene 1 existente no Timeline. 

14. Seleccione Control > Test Movie para ver a execução da aplicação. Passe o rato por 
cima do botão c. 

15. Seleccionar File>Save As do menu principal para gravar o documento com o nome 
aplicacao_10.fla. 

16. Repita os passos 8 a 13 para o botão a. 

17. Seleccione Control > Test Movie para ver a execução da aplicação. Passe o rato por 
cima do botão c. 

18. Seleccionar File>Save As do menu principal para gravar o documento com o nome 
aplicacao_11.fla. 

19. Caso ainda não tenha criado o botão, a inserção de um botão com mais do que um 
estado é mais simples do que criar o botão e executar os passos 8 a 13. Para 
simularmos esta situação, iremos apagar o botão b e criá-lo de raiz tendo em conta 
que queremos que o estado Over seja diferente do estado Up. Seleccione o botão b e 
apague-o. 

 

20. Apague da biblioteca o símbolo bt_b. 

21. Para criar um botão de raiz, seleccione Insert>New Symbol. Este novo símbolo deve 
ser do tipo Button e deve chamar-se bt_b. É automaticamente aberto o timeline 
associado ao botão e o palco é substituído por uma área com a cor de fundo do palco 
para edição do botão. 



L I C Ã O  3  

Carla Teixeira Lopes  59 

 

22. Seleccione a frame do estado Up. Insira uma instância do símbolo quadradoazul, 
arrastando-o desde a biblioteca até ao palco. Coloque-a na posição X=0, Y=0. 

 

23. Através da Text Tool ( ), escreva por cima do quadrado que acabou de 
transformar em símbolo a letra minúscula b. No Property Inspector, altere o tipo de 
letra (Font) para Trebuchet MS, o tamanho da letra (Font Size) para 73, a cor (Text color) 
para #666600 e defina o estilo de letra como negrito (Bold style). Posicione a letra na 
posição X=7, Y=-11. 
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24. Clique com o botão direito na frame do estado Over e escolha a opção Insert 
Kkeyframe. O conteúdo da frame do estado Up é copiado para a frame do estado 
Over. 

 

25. Seleccione a caixa de texto e altere a cor do texto para #D5D7E2. 
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26. Clique com o botão direito no quadrado de forma a seleccioná-lo e escolha a opção 
Swap Symbol. Escolha então o símbolo quadradoverde.  

 

27. Para terminar a edição do botão, clique em Scene 1 existente no Timeline. 
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28. Insira uma instância do símbolo bt_b no palco. Tenha o cuidado de a inserir na frame 
5 e no layer Elemento6. Alinhe-a horizontalmente com os botões c e a e 
verticalmente com a imagem ?. 

 

29. Como criamos este botão de raíz, é necessário definir as acções que lhe estão 
associadas de forma similar ao que foi feito no passo 20 da secção anterior designada 
Criação de botões (a função on (release) fica sem código dentro das chavetas porque 
a opção b é uma opção errada). 

30. Depois de ter inserido as acções respectivas, seleccione Control > Test Movie para 
ver a execução da aplicação. 

31. Seleccionar File>Save As do menu principal para gravar o documento com o nome 
aplicacao_12.fla. 

Inserção de áudio no documento Flash 
O Flash 8 possui várias formas de integração de áudio. É possível inserir áudio que toca 
continuamente, independentemente do timeline, ou inserir áudio sincronizado com a animação.  

Neste tutorial vamos descrever a forma de importação de áudio para o Flash e a associação de 
áudio ao documento Flash e a botões. 

Importação de áudio 

Para a utilização de áudio, é necessário importar previamente os ficheiros respectivos para a 
bibliof. Sem o QuickTime instalado no computador é possível importar os seguintes formatos de 
ficheiros de áudio para o Flash: WAV (só Windows), AIFF (só Macintosh) e MP3 (Windows e 
Macintosh). 
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O Flash armazena os objectos áudio na biblioteca juntamente com os outros símbolos. Tal como 
os outros símbolos, basta uma cópia do ficheiro de áudio para o usar várias vezes no documento. 

Os ficheiros de áudio podem exigir grande espaço em disco e memória do computador. Por este 
motivo é preferível utilizar ficheiros MP3, por ser um formato comprimido e portanto mais 
pequeno que o formato WAV e AIFF. 

Existem muitos ficheiros MP3 disponíveis na Web e poderá fazer os seus próprios ficheiros MP3 
utilizando a aplicação Audacity (http://audacity.sourceforge.net/). 

Associação de áudio ao evento release de um botão 

Na aplicação que tem vindo a ser desenvolvida, podemos tirar partido do som para avisar o 
utilizador se acertou ou falhou na sua escolha em cada desafio. Nesta parte do tutorial iremos 
associar áudio ao evento release de um botão, ou seja, desencadear a execução do áudio sempre 
que o utilizador acabou de clicar no botão (largou o botão do rato). 

Esta associação pode ser feita através dos designados Behaviors ou através da escrita directa do 
código em ActionScript. Iremos de seguida abordar estas duas formas de associação de áudio. Os 
passos iniciais são necessários em qualquer um dos métodos pelo que serão indicados desde já. 

1. Se ainda não tiver o Adobe Macromedia Flash 8 aberto, abra-o. 

2. Abra o documento Flash aplicacao_12.fla. 

3. Para importar o ficheiro de áudio seleccione File > Import > Import to Library. É 
através desta funcionalidade que é possível importar imagens para a biblioteca e 
utilizá-las quando necessário. 

 

4. Na janela que surge, navegue até ao directório que contém o ficheiro áudio. Neste 
caso deverá importar o ficheiro gromb.mp3 (disponibilizado para esta sessão através 
do Moodle). A biblioteca passa a integrar este ficheiro áudio. 
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5. Para podermos utilizar esse ficheiro em código ActionScript necessitamos de lhe 
atribuir um linkage ID, ou seja, um identificador. Para o fazer deverá clicar com o 
botão direito do rato no ficheiro áudio que está na biblioteca e seleccionar Linkage. 
Surge-lhe a seguinte janela. 

 

6. Deverá seleccionar a opção Export for ActionScript.  

 

7. Na caixa Identifier, que entretanto ficou activa, aparece o nome do ficheiro com a 
extensão. Deixe apenas ficar o nome do ficheiro (sem o ponto e a extensão), ou seja, 
gromb. É importante que tenha o cuidado de não utilizar pontos para poder tirar 
partido dos behaviors do Flash. Os behaviors são comportamentos pré-definidos, 
desenvolvidos em ActionScript, que podem ser aplicados às instâncias sem o esforço 
da programação em ActionScript. 
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8. Clique em OK. 

Associação através de Behaviors 

Behaviors são componentes de código ActionScript já escritos que podem ser associados a um 
documento Flash. Estes componentes são úteis para os iniciados no Flash e ActionScript. 

9. Seleccione o botão c.  

 

10. Seleccione Window > Behaviors.  

 

11. Clique no botão +. 

 

12. Seleccione Sound > Load Sound from Library. 
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13. Na janela que surge, escreva o nome do linkage ID que atribuiu anteriormente 
(gromb). Escreva este mesmo nome na segunda caixa de texto. 

 

14. Seleccione Control > Test Movie para ver a execução da aplicação. Experimente 
clicar na tecla c. 

15. Seleccionar File>Save As do menu principal para gravar o documento com o nome 
aplicacao_13.fla. 

Associação através de programação directa em ActionScript 

A associação através de Behaviors foi uma forma de associar código ActionScript ao botão sem o 
estar a escrever. Para utilizadores um pouco mais experientes em ActionScript é possível escrever 
o código directamente em ActionScript. Para demonstrar este tipo de associação, iremos utilizá-la 
na associação do mesmo áudio ao botão b. 

16. Clique com o botão direito no botão b e seleccione a opção Actions.  
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17. Dentro da função on(release) escreva o seguinte código: 

 som = new Sound(this); 

 som.attachSound("gromb"); 

 som.start(); 

Este código cria uma variável chamada som, associa-a ao ficheiro de áudio existente 
na biblioteca e dá início à execução desse ficheiro de áudio. 

 

18. Seleccione Control > Test Movie para ver a execução da aplicação. 
Experimente clicar na tecla b. 

19. Seleccionar File>Save As do menu principal para gravar o documento com o 
nome aplicacao_14.fla. 

20. Utilizando o método que prefere (passos 1 a 13 ou passos 1 a 8 + passos 16 a 17), 
associe o ficheiro de áudio sucesso.mp3 ao botão a. 

21. Seleccione Control > Test Movie para ver a execução da aplicação. 
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22. Seleccionar File>Save As do menu principal para gravar o documento com o 
nome aplicacao_15.fla. 

Associação de áudio a estados de botões  

Na aplicação a desenvolver pode também ser necessário a execução de um ficheiro áudio sempre 
que o utilizador passa com o rato por cima de um botão. Poderá, por exemplo, ser interessante 
complementar uma imagem com um som, ou mesmo apresentar apenas um som e pedir ao 
utilizador para fazer a associação desse som com uma imagem. 

Nesta parte do tutorial iremos criar um novo desafio na frame 15 em que o utilizador a partir de 
um som deve identificar a letra que lhe corresponde. 

1. Se ainda não tiver o Adobe Macromedia Flash 8 aberto, abra-o. 

2. Abra o documento Flash aplicacao_15.fla. 

Inserção de acções nos botões da aplicação 

3. Na frame 10, no layer Navegacao, adicione as acções necessárias aos botões existentes: 
Próximo, Início e Fim, ou seja, que os redireccione para as frames 15 
(_CurrentFrame + 5), 1 e 100, respectivamente. Se estes botões ainda não tiverem o 
seu conteúdo agrupado, deve agrupar o rectângulo e a caixa de texto. Têm de os 
converter para símbolos do tipo Button, cujos nomes devem ser bt_proximo, 
bt_inicio e bt_fim.  

4. Como ainda não tínhamos feito o mesmo no botão Início e Fim da frame 5, iremos 
aproveitar os símbolos criados no passo 3. Estando posicionada na frame 10, clique 
com o botão direito em cima do botão Início e seleccione a opção Copy.  

5. Posicionando-se na frame 5, layer Navegacao, apague a caixa relativa ao botão Início. 

6. Seleccione do menu principal a opção Edit > Paste in Place. 

7. Repita os passos 4 a 6 para o botão Fim. 

8. Copie o botão Iniciar existente na frame 1, layer Cabecalho e cole-o (através do 
comando Paste in Place) na frame 100 do mesmo layer. 

Criação do conteúdo da frame do segundo desafio 

9. Clique com o botão direito do rato na frame 15 do layer Cabecalho e seleccione Insert 
Blank Keyframe. Repita o passo para todos os outros layers, com excepção do layer 
ActionScript. 
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10. Como a estrutura da frame associada a este desafio não difere do primeiro desafio, 
vamos aproveitar o que já foi feito na frame 5. Com o botão direito do rato clique na 
frame 5 do layer Cabecalho e seleccione Copy Frames.  

11. Clique com o botão direito do rato na frame 15 do layer Cabecalho e seleccione Paste 
Frames.  

 

12. Repita os passos 10 e 11 para os layers Conteudo, Grupo1, Grupo2, Elemento4, 
Elemento5, Elemento6 e Navegacao. Não iremos copiar os layers Elemento1, 
Elemento2 e Elemento3 porque vamos querer que o Grupo 1 tenha elementos 
diferentes. 

 

13. Altere o texto existente no Cabeçalho para Desafio 2 e Clique no elemento do 
grupo 2 que corresponde ao som do do grupo 1. Para ouvir passe o rato por 
cima do elemento do grupo 1. 
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14. No grupo 1 iremos inserir uma imagem que funcionará como um pseudo-botão, ou 
seja, permitirá associar eventos à imagem, mas se o utilizador clicar na imagem não 
acontecerá nada. Para importar a imagem para a biblioteca, seleccione File > Iimport 
to Library e escolha o ficheiro semsom.jpg. O ficheiro passará a constar na 
biblioteca. 

15. Repita o passo 14 para o ficheiro comsom.jpg. 

16. Clique na frame 15 do layer Elemento2 e arraste o símbolo semsom.jpg. Alinhe o seu 
centro horizontal com o da letra a. 

 

17. Clique com o botão direito em cima da imagem que acabou de colocar no palco e 
seleccione Convert to Symbol. Dê-lhe o nome de bt_som_a. Este símbolo deve ser 
do tipo Button. 

 

Mudança de imagem no estado Over do novo botão 

18. Dê um duplo clique em cima do novo botão para que seja possível editá-lo. 
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19. Clique com o botão direito na frame do estado Over e seleccione Insert Keyframe. 

20. Estando na frame do estado Over, clique com o botão direito em cima da imagem do 
botão e escolha Swap Bitmap. Escolha a imagem comsom.jpg. 

21. Para terminar a edição do botão, clique em Scene 1 existente no Timeline. 

22. Seleccione Control > Test Movie para ver a execução da aplicação. Passe o rato por 
cima do botão que acabou de criar. 

23. Seleccionar File>Save As do menu principal para gravar o documento com o nome 
aplicacao_16.fla. 

Inserção de som no estado Over 

24. Importe o ficheiro de áudio a.mp3. Atribua-lhe o linkage ID a.  

25. Dê um duplo clique em cima do novo botão para que seja possível editá-lo. 
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26. Posicione-se na frame Over. O Property Inspector fica como a imagem seguinte. 

 

27. Na caixa de selecção Sound do Property Inspector, seleccione o ficheiro a.mp3. 

28. Para terminar a edição do botão, clique em Scene 1 existente no Timeline. 

29. Seleccione Control > Test Movie para ver a execução da aplicação. Passe o rato por 
cima do botão que acabou de criar. 

30. Seleccionar File>Save As do menu principal para gravar o documento com o nome 
aplicacao_17.fla. 

Drag and Drop no Flash 
Outra interactividade que pode ser necessária, especialmente nos desafios que envolvam 
ordenação de elementos, é a possibilidade do utilizador clicar num elemento, arrastá-lo e largá-lo 
noutro local do palco. A este comportamento chama-se Drag and Drop (Arrasta e Larga). 

Nesta secção, iremos criar um novo desafio (o terceiro), em que o utilizador terá de ordenar 3 
elementos. Inicialmente iremos criar ecrãs que são necessários para que esta pequena aplicação 
funcione de forma integrada. Começaremos por construir o ecrã de resposta ao desafio 2 e o ecrã 
do desafio 3. Apenas nas secções Inserção da interactividade Drag and Drop e Passagem 
para a frame de resposta ao desafio, serão apresentadas as técnicas específicas para 
implementação de Drag and Drop. No entanto, é necessário salientar, que mesmo nestas secções, 
muitos dos passos existem porque estamos a utilizar elementos que já foram utilizados 
previamente e necessitam de ser convertidos. Para a implementação de Drag and Drop apenas é 
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necessário compreender os passos 26 e 40, onde é apresentado o código ActionScript que o 
implementa Além disso é necessário que os dois elementos envolvidos (o que se move e aquele 
que deve “receber” o objecto que se move) devem ser do tipo Movie. 

1. Se ainda não tiver o Adobe Macromedia Flash 8 aberto, abra-o. 

2. Abra o documento Flash aplicacao_17.fla. 

Criação de ecrã de resposta ao desafio criado na etapa anterior 

3. Clique com o botão direito do rato na frame 20 do layer Cabecalho e seleccione 
Insert Blank Keyframe. Repita o passo para todos os outros layers, com excepção do 
layer ActionScript. 

 

4. Como a estrutura da frame associada a esta resposta não difere da resposta ao primeiro 
desafio, vamos aproveitar o que já foi feito na frame 10. Com o botão direito do rato 
clique na frame 10 do layer Cabecalho e seleccione Copy Frames.  

5. Clique com o botão direito do rato na frame 20 do layer Cabecalho e seleccione Paste 
Frames.  

 

6. Repita os passos 4 e 5 para os layers Conteudo, Grupo1, Grupo2, Elemento3, 
Elemento4 e Navegacao.  
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7. Altere a caixa de texto do layer Cabecalho para Desafio 2. Altere a posição da letra a 
para as coordenadas x=170 e y=155. Altere também o conteúdo da caixa de texto 
que está no layer Elemento4 para O som que ouviu é realmente o som associado 
à vogal a. 

 

8. Seleccione Control > Test Movie para ver a execução da aplicação.  

9. Seleccionar File>Save As do menu principal para gravar o documento com o nome 
aplicacao_18.fla. 

Criação do ecrã do Desafio 3 

10. Clique com o botão direito do rato na frame 25 do layer Cabecalho e seleccione 
Insert Blank Keyframe. Repita o passo para todos os outros layers, com excepção do 
layer ActionScript. 

 

11. Como a estrutura da frame associada a este desafio não difere do primeiro desafio, 
vamos aproveitar o que já foi feito na frame 5. Com o botão direito do rato clique na 
frame 5 do layer Cabecalho e seleccione Copy Frames.  
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12. Clique com o botão direito do rato na frame 25 do layer Cabecalho e seleccione Paste 
Frames.  

 

13. Repita os passos 11 e 12 para os layers Conteudo, Grupo1, Grupo2, Elemento4, 
Elemento5, Elemento6 e Navegacao.  

 

14. Altere as caixas de texto do layer Cabecalho para Desafio 3 e Ordene os elementos 
do Grupo 2, colocando-os no Grupo 1. 

 

15. Insira 3 vezes o elemento quadradoazul da biblioteca na caixa associada ao Grupo 1. 
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16. Seleccione Control > Test Movie para ver a execução da aplicação.  

17. Seleccionar File>Save As do menu principal para gravar o documento com o nome 
aplicacao_19.fla. 

Inserção da interactividade Drag and Drop 

18. Seleccione o quadradoazul que pertence ao layer Elemento1 e no Property Inspector 
altere o seu tipo para Movie Clip e dê um nome à instância: fr25_caixa1. 

 

19. Repita o passo 18 para os quadrados dos layers Elemento2 e Elemento3. Os nomes 
das instâncias devem ser respectivamente fr25_caixa2 e fr25_caixa3. 

20. Clique com o botão direito no botão da letra c que pertence ao layer Elemento4 e 
seleccione Duplicate Symbol. O nome do novo símbolo deverá ser mv_c. 

21. Clique com o botão direito no símbolo mv_c na biblioteca e seleccione Type > 
Movie Clip. 

22. Clique com o botão direito no símbolo mv_c na biblioteca e seleccione Edit.  

23. Clique com o botão direito na frame 2 do timeline do filme mv_c e seleccione Remove 
Frames. Esta operação irá permitir eliminar a animação que tínhamos colocado no 
desafio 1. 

24. No timeline, clique em Scene 1 para voltar ao timeline principal. 

25. Seleccione a instância do botão mv_c e, no Property Inspector, mude o tipo da instância 
para Movie Clip. Irá aparecer uma janela de aviso (que o código de ActionScript já 
definido irá ser eliminado) à qual deverá responder ok. 

26. Clique com o botão direito em cima da instância do símbolo mv_c e seleccione 
Actions. Na janela das acções insira o seguinte código: 
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Este código é que permitirá que o símbolo mv_c se possa arrastar e, caso esteja 
dentro do objecto chamado fr25_caixa3, seja inserido neste último. É importante 
que o compreenda. Vamos analisá-lo passo a passo. 

O primeiro bloco de instruções: 

on(press) { 
 startDrag(this); 
} 

diz que, quando este objecto (mv_c, ou seja o objecto ao qual estamos a adicionar as 
acções) for pressionado (on(press)), o Flash deve permitir arrastá-lo 
(startDrag(this)). O this é um termo que permite identificar o objecto ao qual 
se estão a adicionar as acções. 

O segundo bloco de instruções: 

on(release) { 
 stopDrag(); 
 if (this._droptarget == "/fr25_caixa3") { 
  this._x = _root.fr25_caixa3._x; 
  this._y = _root.fr25_caixa3._y-20; 

} 
 else{ 
  this._x = 50; 
  this._y = 285.1; 
 } 
} 

dá indicações sobre o que fazer quando se larga (on(release)) o botão do rato do 
objecto (mv_c). A primeira instrução (stopDrag()), indica que o Flash deverá parar 
de arrastar o objecto.  
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A segunda instrução é uma estrutura condicional, ou seja, o Flash terá de verificar se 
a condição this._droptarget == "/fr25_caixa3" é verdadeira ou não. Esta 
instrução de ActionScript permite verificar se o objecto foi “largado” em cima do 
objecto com o nome fr25_caixa3.  

Caso esta condição seja verdade, são executadas as seguintes instruções: 

this._x = _root.fr25_caixa3._x; 
this._y = _root.fr25_caixa3._y-20; 

Estas instruções indicam ao Flash que coloque o objecto mv_c nas coordenadas do 
elemento com o nome fr25_caixa3. É ainda necessário explicar a razão da 
subtracção de 20 à coordenada y do objecto fr25_caixa23. Foi necessário recorrer a 
esta artimanha para se conseguir que o objecto mv_c ficasse exactamente por cima 
do objecto fr25_caixa3 porque, devido à existência de letras no objecto mv_c, a sua 
altura é superior à altura do objecto fr25_caixa3. Repare na diferença de altura na 
figura abaixo. 

 

No seu caso, a compensação em termos de altura poderá ser diferente de 20. Terá de 
fazer alguns testes para acertar com a compensação a efectuar.  

Caso a condição (this._droptarget == "/fr25_caixa3" ) não seja verdade 
(else), são executadas as seguintes instruções: 

this._x = 50; 
this._y = 285.1; 

Estas instruções indicam ao Flash que coloque o objecto nas coordenadas onde 
estava inicialmente. Antes de escrever este código, é necessário determinar as 
coordenadas onde se pretende colocar o objecto, caso o utilizador falhe a colocá-lo 
na ordem correcta. Em princípio será a posição que ele ocupava antes de o utilizador 
lhe ter tocado pela primeira vez. 

27. Repita os passos 20 a 26 para as letras a e b. Não se esqueça de fazer as alterações 
respectivas ao código (substituir fr25_caixa3 pelo nome do elemento onde a letra 
deverá estar associada e alterar as coordenadas da posição inicial das letras). Os nomes 
dos novos símbolos devem ser mv_a e mv_b. Também poderá ter de fazer alguns 
ajustes à posição final do elemento quando a opção está correcta. 

28. Seleccione Control > Test Movie para ver a execução da aplicação. Experimente 
clicar e arrastar os elementos do Grupo 2. 

29. Seleccionar File>Save As do menu principal para gravar o documento com o nome 
aplicacao_20.fla. 
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Criação do ecrã de resposta ao desafio 

30. Clique com o botão direito do rato na frame 30 do layer Cabecalho e seleccione 
Insert Blank Keyframe. Repita o passo para todos os outros layers, com excepção do 
layer ActionScript. 

 

31. Como a estrutura da frame associada a esta resposta não difere da resposta ao primeiro 
desafio, vamos aproveitar o que já foi feito na frame 10. Com o botão direito do rato 
clique na frame 10 do layer Cabecalho e seleccione Copy Frames.  

32. Clique com o botão direito do rato na frame 30 do layer Cabecalho e seleccione Paste 
Frames.  

 

33. Repita os passos 31 e 32 para os layers Conteudo, Grupo1, Grupo2, Elemento4 e 
Navegacao.  

 

34. Altere a caixa de texto do layer Cabecalho para Desafio 3. Altere também o 
conteúdo da caixa de texto que está no layer Elemento4 para De acordo com o 
abecedário, a sequência correcta é a, b, c. 
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35. Posicione-se na frame 25 e copie o quadradoazul com a letra a. 

36. Posicione-se na frame 30, layer Elemento1 e cole o quadradoazul com a letra Coloque-
o no primeiro lugar da sequência da Solução. 

 

37. Com o quadradoazul da letra a seleccionado, mude o tipo de instância para Graphic 
no Property Inspector. Deverá responder OK a mensagem de aviso de eliminação do 
código de ActionScript. 

 

38. Repita os passos 35 a 37 para os quadrados azuis com as letras b e c. Estes quadrados 
devem ser inserido nos layers Elemento2 e Elemento3. 

 

39. Seleccionar File>Save As do menu principal para gravar o documento com o nome 
aplicacao_21.fla. 
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Passagem para a frame de resposta ao desafio 

Após ter implementado o Drag and Drop, é necessário detectar quando é que o utilizador 
completou correctamente o desafio, ou seja, completou a sequência de elementos. Neste 
momento o utilizador é direccionado para o ecrã que apresenta a explicação da solução. Enquanto 
não o conseguir, deverá continuar a tentar.  

Caso não existisse a verificação que se irá implementar nesta etapa do tutorial, o utilizador não 
sairia mais deste ecrã, a não ser que carregasse no botão Início ou Fim. 

40. De forma semelhante ao que fez nos passos 18 e 19, atribua nomes aos quadrados 
com as letras c, a e b (dos layers 4,5 e 6 respectivamente). Os nomes das instâncias 
devem ser respectivamente fr25_obj3, fr25_obj1 e fr25_obj2. Estes nomes 
foram definidos em função do número da caixa de destino correcta. 

41. Clique com o botão direito no quadrado azul com a letra c e seleccione Actions. Ao 
código já associado, terá de acrescentar o que está a negrito no código abaixo. 

on(press) { 
 startDrag(this); 
} 
on(release) { 
 stopDrag(); 
 if (this._droptarget == "/fr25_caixa3") { 
  this._x = _root.fr25_caixa3._x; 
  this._y = _root.fr25_caixa3._y-20; 
  if (_root.fr25_obj1._x == _root.fr25_caixa1._x && 
_root.fr25_obj1._y == _root.fr25_caixa1._y-20 && 
_root.fr25_obj2._x == _root.fr25_caixa2._x && 
_root.fr25_obj2._y == _root.fr25_caixa2._y && 
_root.fr25_obj3._x == _root.fr25_caixa3._x && 
_root.fr25_obj3._y == _root.fr25_caixa3._y-20){ 
   _root.gotoAndStop (_root._currentFrame + 5); 
  } 
 } 
 else{ 
  this._x = 50; 
  this._y = 285.1; 
 } 
} 

Esta nova condição verifica se quando o objecto (neste caso mv_c) é largado, as coordenadas x e 
y de todos os objectos do Grupo 2 coincidem com as coordenadas das posições finais (ou seja, 
por cima dos objectos fr25_caixa1, fr25_caixa2 e fr25_caixa3). Se isto for verdade, o 
Flash deverá direccionar o utilizador para a frame que está associada ao ecrã de resultado 
(_root.gotoAndStop (_root._currentFrame + 5)). 

42. Repita o passo 40 para os outros dois elementos (a e b) do Grupo 2. 

43. Seleccione Control > Test Movie para ver a execução da aplicação. Experimente 
clicar e arrastar todos os elementos do Grupo 2 para a sequência correcta. 
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44. Seleccionar File>Save As do menu principal para gravar o documento com o nome 
aplicacao_22.fla. 

45. Colocar o documento disponível na sua área do servidor Web da ESTSP. Se for 
necessário consulte a lição 1. 

46. A sua aplicação deverá ser semelhante à existente em 
http://www.estsp.pt/~ctl/docencia/20072008/1sem/tato/tutoriais/aplicacao_final.html 

 

 


